Network Status Updates

All systems are operational.

Last updated 2 weeks ago

cPanel Security Updates

3 years ago 2022-11-15 05:35 UTC
Fixed

Fixed

3 years ago 2022-11-15 19:47 UTC

Updates have completed successfully. Thank you for your patience.

Reported

3 years ago 2022-11-15 05:35 UTC

Our Systems Team is currently conducting security updates that will results in quick service restarts, customers may see services down for a few minutes before coming back up. Thank you for your patience while we keep our servers secure.